无敌战狼选股公式

发布时间:2024-02-25

选股公式源码

ABC1:=CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2);
ABC2:=REF(ABC1,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC3:=REF(ABC2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC4:=REF(ABC3,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC5:=REF(ABC4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC6:=REF(ABC5,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC7:=REF(ABC6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC8:=REF(ABC7,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC9:=REF(ABC8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABCA:=REF(ABC9,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABCB:=REF(ABCA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABCC:=REF(ABCB,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABCD:=CLOSE< REF(CLOSE,1) AND CLOSE< REF(CLOSE,2);
ABCE:=REF(ABCD,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABCF:=REF(ABCE,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC10:=REF(ABCF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC11:=REF(ABC10,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC12:=REF(ABC11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC13:=REF(ABC12,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC14:=REF(ABC13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC15:=REF(ABC14,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC16:=REF(ABC15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC17:=REF(ABC16,1) AND CLOSE<=REF(CLOSE,1) AND CLOSE>=REF(CLOSE,2);
ABC18:=REF(ABC17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE<=REF(CLOSE,2);
ABC19:=REF(ABCD OR ABCE OR ABCF OR ABC10 OR ABC11 OR ABC12 OR ABC13 OR ABC14 OR ABC15 OR ABC16 OR ABC17 OR ABC18,1) AND ABC1;
ABC1A:=REF(ABC1 OR ABC2 OR ABC3 OR ABC4 OR ABC5 OR ABC6 OR ABC7 OR ABC8 OR ABC9 OR ABCA OR ABCB OR ABCC,1) AND ABCD;
DIFF:= EMA(CLOSE,9) - EMA(CLOSE,26);
DEA:=EMA(DIFF,12);
MACD:=2*(DIFF-DEA);
ZC:=50*(IF(macd>REF(MACD,1) AND REF(MACD,1)>0 AND REF(MACD,2)>REF(MACD,1),0.2,0));
XG:ABC19 AND C>EMA(C,7) AND MACD.MACD>0 AND ZC AND V/REF(VOL,1)>1.9 AND C>REF(C,1);

选股公式翻译

ABC1赋值:收盘价>1日前的收盘价 AND 收盘价>2日前的收盘价
ABC2赋值:1日前的ABC1 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC3赋值:1日前的ABC2 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC4赋值:1日前的ABC3 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC5赋值:1日前的ABC4 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC6赋值:1日前的ABC5 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC7赋值:1日前的ABC6 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC8赋值:1日前的ABC7 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC9赋值:1日前的ABC8 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABCA赋值:1日前的ABC9 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABCB赋值:1日前的ABCA AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABCC赋值:1日前的ABCB AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABCD赋值:收盘价< 1日前的收盘价 AND 收盘价< 2日前的收盘价
ABCE赋值:1日前的ABCD AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABCF赋值:1日前的ABCE AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC10赋值:1日前的ABCF AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC11赋值:1日前的ABC10 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC12赋值:1日前的ABC11 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC13赋值:1日前的ABC12 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC14赋值:1日前的ABC13 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC15赋值:1日前的ABC14 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC16赋值:1日前的ABC15 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC17赋值:1日前的ABC16 AND 收盘价<=1日前的收盘价 AND 收盘价>=2日前的收盘价
ABC18赋值:1日前的ABC17 AND 收盘价>=1日前的收盘价 AND 收盘价<=2日前的收盘价
ABC19赋值:1日前的ABCDORABCEORABCFORABC10ORABC11ORABC12ORABC13ORABC14ORABC15ORABC16ORABC17ORABC18 AND ABC1
ABC1A赋值:1日前的ABC1ORABC2ORABC3ORABC4ORABC5ORABC6ORABC7ORABC8ORABC9ORABCAORABCBORABCC AND ABCD
DIFF赋值: 收盘价的9日指数移动平均 - 收盘价的26日指数移动平均
DEA赋值:DIFF的12日指数移动平均
MACD赋值:2*(DIFF-DEA)
ZC赋值:50*(如果MACD>1日前的MACDANDREF(MACD,1)>0ANDREF(MACD,2)>1日前的MACD,返回0.2,否则返回0)
输出XG:ABC19 AND 收盘价>收盘价的7日指数移动平均 AND MACD.MACD>0 AND ZC AND 成交量(手)/1日前的成交量(手)>1.9 AND 收盘价>1日前的收盘价

演示图片

s_15921.png

相关选股公式

  1. 均线成交量MACD金叉选股公式
  2. 九方小牛选股公式
  3. 势如破竹选股公式
  4. 倍量龙妖选股公式
  5. 九天揽月选股公式
  6. 绝密爆点选股公式
  7. 探底棒选股公式
  8. 红色神剑选股公式
  9. 黎明之星选股公式
  10. MACD绿柱翻红选股公式