零上第一次金选股公式

发布时间:2021-03-21

选股公式源码

JQRS:=INBLOCK('近期弱势')>0;
YGSZ:=INBLOCK('预高送转')>0;
RZRQ:=INBLOCK('融资融券')>0;
SYJZ:=INBLOCK('商誉减值')>0 AND  FINANCE(54)>0;
GSY:=INBLOCK('高商誉')>0;
JQJJ:=INBLOCK('近期解禁');
NJC:=INBLOCK('拟减持');
GGJC:=INBLOCK('高管减持');
FXTS:=INBLOCK('风险提示');
YJYJ:=INBLOCK('业绩预降');
GSG:=INBLOCK('亏损股');
HSZJ:=INBLOCK('户数增加');
GZYG:=INBLOCK('高质押股');
GQFS:=INBLOCK('股权分散');
LXGS:=INBLOCK('连续亏损');
KFKS:=INBLOCK('扣非亏损')>0;
一字板:=NOT(C/REF(C,1)>1.095 AND H=O AND L=H);
去除ST股:=IF(NAMELIKE('S'),0,1) AND IF(NAMELIKE('*'),0,1);
去除停牌:=DYNAINFO(8)>0;
去除星股:=IF(NAMELIKE('*'),0,1);
去无用股:=去除ST股 AND 去除停牌 AND 去除星股 AND NOT(GSY) AND NOT(JQRS)  AND NOT(LXGS) AND NOT(KFKS)  AND NOT(YGSZ) AND NOT(NJC)  AND NOT(JQJJ) AND NOT(SYJZ)
AND NOT(YJYJ) AND NOT(GGJC) AND NOT(FXTS)  AND NOT(GSG) AND NOT(HSZJ) AND NOT(GQFS) AND NOT (CODELIKE('688') )  AND FINANCE(33)>0 AND FINANCE(54)>0 AND CAPITAL<30000000 ;{每股收益,扣非净利润至少一千万以上};
DIF:=EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:=EMA(DIF,9);
MACD:=2*(DIF-DEA);
EXIST(CROSS(DIF,0),26) AND CROSS(DIF,DEA) AND BETWEEN(DIF,0,1) AND 去无用股,COLORMAGENTA,LINETHICK3;

选股公式翻译

JQRS赋值:属于某板块>0
YGSZ赋值:属于某板块>0
RZRQ赋值:属于某板块>0
SYJZ赋值:属于某板块>0 AND 扣非净利润>0
GSY赋值:属于某板块>0
JQJJ赋值:属于某板块
NJC赋值:属于某板块
GGJC赋值:属于某板块
FXTS赋值:属于某板块
YJYJ赋值:属于某板块
GSG赋值:属于某板块
HSZJ赋值:属于某板块
GZYG赋值:属于某板块
GQFS赋值:属于某板块
LXGS赋值:属于某板块
KFKS赋值:属于某板块>0
去一字板赋值:取反
去除ST股赋值:如果模糊匹配品种名称,返回0,否则返回1 AND 如果模糊匹配品种名称,返回0,否则返回1
去除停牌赋值:总量>0
去除星股赋值:如果模糊匹配品种名称,返回0,否则返回1
去无用股赋值:去除ST股 AND 去除停牌 AND 去除星股 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 取反 AND 每股收益(全年折算)>0 AND 扣非净利润>0 AND 当前流通股本(手)<30000000 

DIF赋值:收盘价的12日指数移动平均 - 收盘价的26日指数移动平均
DEA赋值:DIF的9日指数移动平均
MACD赋值:2*(DIF-DEA)
最近26日存在DIF上穿0 AND DIF上穿DEA AND DIF位于0和1之间 AND 去无用股,画洋红色,线宽为3

演示图片

s_14091.png

相关选股公式

  1. MACD钝化结构形成选股公式
  2. 线上擒牛选股公式
  3. 妖牛启动选股公式
  4. MACD凹底淘金选股公式
  5. 钻石拉升选股公式
  6. 回踩起飞选股公式
  7. 背离前启动点选股公式
  8. 等你飞选股公式
  9. 金叉MACD选股公式
  10. MACD日周月共振选股公式