惊鸿一剑选股公式

发布时间:2021-10-16

选股公式源码

X_1:=maX(MA(CLOSE,5),MAX(MAX(MA(CLOSE,10),MA(CLOSE,20)),MAX(MA(CLOSE,60),MA(CLOSE,120))));
X_2:=IF(CODELIKE(37),0,1);
X_3:=IF(NAMELIKE(38),0,1);
X_4:=IF(NAMELIKE(39),0,1);
X_5:=DYNAINFO(17)>0;
X_6:=X_2 AND X_3 AND X_4 AND X_5;
X_7:=REF(CLOSE,1)<REF(X_1,1) AND CLOSE>X_1;
X_8:=ATAN((MA(CLOSE,3)/REF(MA(CLOSE,3),1)-1)*100)*180/3.141159>45;
X_9:=MA(CLOSE,34);
X_10:=MA(CLOSE,55);
X_11:=MA(CLOSE,89);
X_12:=MA(CLOSE,120);
X_13:=CLOSE>X_9 AND X_9>X_10 AND X_10>X_11 AND X_11>X_12 AND CLOSE>OPEN;
X_14:=VOL>REF(VOL,20)*1.55;
打劫:X_7 AND X_6 AND SUM(100*VOL/CAPITAL,2)>=5.1 AND RANGE(CAPITAL/100,3000,200000) AND IF(COUNT(X_8,3)>=1,1,0) AND X_13 AND X_14 AND CROSS(KDJ.J,KDJ.K);

选股公式翻译

X_1赋值:收盘价的5日简单移动平均和收盘价的10日简单移动平均和收盘价的20日简单移动平均的较大值和收盘价的60日简单移动平均和收盘价的120日简单移动平均的较大值的较大值的较大值
X_2赋值:如果模糊匹配品种代码,返回0,否则返回1
X_3赋值:如果模糊匹配品种名称,返回0,否则返回1
X_4赋值:如果模糊匹配品种名称,返回0,否则返回1
X_5赋值:量比>0
X_6赋值:X_2 AND X_3 AND X_4 AND X_5
X_7赋值:1日前的收盘价<1日前的X_1 AND 收盘价>X_1
X_8赋值:(收盘价的3日简单移动平均/1日前的收盘价的3日简单移动平均-1)*100的反正切*180/3.141159>45
X_9赋值:收盘价的34日简单移动平均
X_10赋值:收盘价的55日简单移动平均
X_11赋值:收盘价的89日简单移动平均
X_12赋值:收盘价的120日简单移动平均
X_13赋值:收盘价>X_9 AND X_9>X_10 AND X_10>X_11 AND X_11>X_12 AND 收阳线
X_14赋值:成交量(手)>20日前的成交量(手)*1.55
输出打劫:X_7 AND X_6 AND 100*成交量(手)/当前流通股本(手)的2日累和>=5.1 AND 当前流通股本(手)/100位于3000和200000之间 AND 如果统计3日中满足X_8的天数>=1,返回1,否则返回0 AND X_13 AND X_14 AND KDJ的J上穿KDJ的K

演示图片

s_14430.png

相关选股公式

  1. 极限抄底选股公式
  2. 凤凰涅槃选股公式
  3. 牛熊不败选股公式
  4. 豹子抓板选股公式
  5. 起暴狙击点选股公式
  6. 底部精准抄底选股公式
  7. 极底介入选股公式
  8. 涨买入选股公式
  9. 老妖启动选股公式
  10. 低开大肉选股公式